Grave errore durante aggiornamento a 3.2

Supporto per phpBB 3.2.x.
Rispondi
Neurofisiologia
Utente
Utente
Messaggi: 53
Iscritto il: 13/07/2011, 8:44
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.3.27
Database: MySQL 5.0.92-enterprise-gpl-log
Contatta:

Grave errore durante aggiornamento a 3.2

Messaggio da Neurofisiologia » 19/03/2017, 16:09

Volevo passare dall'attuale versione del Forum 3.1.10 alla 3.2 purtroppo mi è apparso un messaggio di errore che non mi ha permesso di procedere

Parse error: syntax error, unexpected '[' in /web/htdocs/www.xxxxxxxxxxxx.net/home/phpbb/vendor/react/promise/src/functions.php on line 15


Ma la cosa più grave è che nemmeno dopo il ripristino del backup dei file e nemmeno del DB riesco più a vedere il forum !!!! Il messaggio è il seguente

Warning: require(/web/htdocs/www.xxxxxxxxxxxx.net/home/phpbb/vendor/symfony/polyfill-mbstring/bootstrap.php): failed to open stream: No such file or directory in /web/htdocs/www.xxxxxxxxxxxx.net/home/phpbb/vendor/composer/autoload_real.php on line 55 Warning: require(/web/htdocs/www.xxxxxxxxxxxx.net/home/phpbb/vendor/symfony/polyfill-mbstring/bootstrap.php): failed to open stream: No such file or directory in /web/htdocs/www.xxxxxxxxxxxx.net/home/phpbb/vendor/composer/autoload_real.php on line 55 Fatal error: require(): Failed opening required '/web/htdocs/www.xxxxxxxxxxxx.net/home/phpbb/vendor/symfony/polyfill-mbstring/bootstrap.php' (include_path='.:/php5.3/lib/php/') in /web/htdocs/www.xxxxxxxxxxxx.net/home/phpbb/vendor/composer/autoload_real.php on line 55



Avete qualche idea su come posso risolvere ??

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7204
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Grave errore durante aggiornamento a 3.2

Messaggio da Angolo » 19/03/2017, 16:32

Hai effettuato il ripristino con la sovrascrittura? Se sì, prima cancella, elimina tutto il contenuto ftp e tutto il database. Dopo, su database attivo e vuoto (zero tabelle) e su contenuto ftp vuoto, effettua il ripristino completo. Ovviamente, si presume che il backup sia stato effettuato quando il Forum era perfettamente funzionante.


P.S.
Se fatto dopo aver fatto quanto ho detto, il problema sussiste, quasi sicuramente, qualcuno (il tuo host) o qualcosa, ha modificato i permessi delle cartelle e dei file. Nel qual caso, segnala la cosa all'host, ma dopo aver eseguito per bene quanto sopra indicato.

Neurofisiologia
Utente
Utente
Messaggi: 53
Iscritto il: 13/07/2011, 8:44
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.3.27
Database: MySQL 5.0.92-enterprise-gpl-log
Contatta:

Re: Grave errore durante aggiornamento a 3.2

Messaggio da Neurofisiologia » 19/03/2017, 16:59

Certamente, il forum era perfettamente funzionante.....ora riprovo cancellando di nuovo tutti i file e le cartelle...dubito che Aruba mi abbia modificato i permessi durante il breve trascorso di tutta la procedura...

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7204
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Grave errore durante aggiornamento a 3.2

Messaggio da Angolo » 19/03/2017, 17:05

Cartelle e tabelle!!!

Neurofisiologia
Utente
Utente
Messaggi: 53
Iscritto il: 13/07/2011, 8:44
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.3.27
Database: MySQL 5.0.92-enterprise-gpl-log
Contatta:

Re: Grave errore durante aggiornamento a 3.2

Messaggio da Neurofisiologia » 19/03/2017, 17:20

Appena rifatta tutta la procedura:

1-cancellato tutto il db e ripristinato il backup senza nessun errore
2-cancellato tutto il contenuto remoto del forum e ripristinato da backup

mi collego e vedo lo stesso errore !

se guardiamo la prima stringa di errore cioè

Warning: require(/web/htdocs/www.xxxxxx.net/home/phpbb/vendor/symfony/polyfill-mbstring/bootstrap.php)

sembra che all'interno della cartella vendor ci dovrebbe essere una cartella symfony...andando a vedere sul backup funzionante nella cartella vendor io ho solamente:

/composer
/lusitanian
autoload.php

quindi ritengo che la cartella symfony sia compresa solamente nel vendor dei file di aggiornamento ! Perchè mi restituisce quell'errore ?

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7204
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Grave errore durante aggiornamento a 3.2

Messaggio da Angolo » 19/03/2017, 17:33

Se il backup era integro e hai davvero cancellato tutto (ftp e database) prima di ripristinare, non può che essere un problema di host o di pemessi di file e cartelle. Prova ne sarebbe, poter effettuare il ripristino in locale o presso altro host, con quel medesimo backup.

Se col medesimo backup l'errore si ripete in locale o presso altro host, allora il backup è compromesso.
Ma è improbabile, in base a quello che hai riferito.

Neurofisiologia
Utente
Utente
Messaggi: 53
Iscritto il: 13/07/2011, 8:44
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.3.27
Database: MySQL 5.0.92-enterprise-gpl-log
Contatta:

Re: Grave errore durante aggiornamento a 3.2

Messaggio da Neurofisiologia » 19/03/2017, 17:47

Allora ho risolto in questa maniera, ho mantenuto il db e tutto il backup appena ripristinato, sono andato su phpbb.com e ho scaricato la versione 3.1.10, ho preso da questa versione tutta la maledetta cartella vendor dopodichè l'ho caricata via ftp senza sostituire file o cartelle già presenti, in questo modo ho ripristinato la visione del Forum, grazie a dio....confrontando le due cartelle vendor c'è qualcosa che non mi torna, perchè sul mio backup ho:

vendor
/composer
/lusitanian
autoload.php

sulla cartella vendor della 3.1.10 scaricata (ora sul server) invece ho:

vendor
/composer
/lusitanian
/psr
/symfony
/twig
autoload.php

perchè ci sono tre cartelle in più ? L'errore in aggiornamento è stato dato proprio su questa cartella...

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7204
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Grave errore durante aggiornamento a 3.2

Messaggio da Angolo » 19/03/2017, 18:03

È possibile che alcune cartelle, siano state rese "incancellabili", causa permessi. Questo spiegherebbe la differenza.

Neurofisiologia
Utente
Utente
Messaggi: 53
Iscritto il: 13/07/2011, 8:44
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.3.27
Database: MySQL 5.0.92-enterprise-gpl-log
Contatta:

Re: Grave errore durante aggiornamento a 3.2

Messaggio da Neurofisiologia » 19/03/2017, 20:15

Scusa Angolo porta pazienza ma non ho capito, é giusto che ho quelle tre cartelle o no ? Ci devono essere all'interno di vendor ? :roll:

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7204
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Grave errore durante aggiornamento a 3.2

Messaggio da Angolo » 20/03/2017, 12:32

In teoria, dovrebbero essere presenti solo le cartelle presenti nel pacchetto originale della 3.2.X. In pratica non è detto, dal momento che alcune cose discutibili, sono state effettuate con queste nuove versioni.

Occorrerebbe effettuare dei test. Se il Forum così funziona, lascia tutto così, e caso mai, procedi con test e prove in locale o presso altro host, utilizzando il medesimo contenuto ftp e lo stesso database.

Rispondi

Torna a “[3.2.x] Forum di Supporto”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite