Errore in aggiornamento...

Supporto per phpBB 3.2.x.
roybell
Utente
Utente
Messaggi: 5
Iscritto il: 13/01/2017, 9:15
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux

Errore in aggiornamento...

Messaggio da roybell » 13/01/2017, 9:59

Ciao a tutti,
ho un forum di test in cui ho provato ad effettuare l'aggiornamento da 3.1.10 a 3.2
Ho scaricato le cartelle (vendor, docs, install) e le ho inviate nella root del forum.
Successivamente ho eseguito l'aggiornamento, ma prima di aggiornare il database (nella pagina in cui venivano elencati i file da eliminare, aggiornare ecc...) mi è comparso questo errore:

"The installer detected a timeout
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI."

Se torno in admin leggo:

"La tua installazione di phpBB non è stata correttamente aggiornata. Leggi le informazioni qui di seguito, per correggere questo errore.

Versioni dei file
3.2.0
Versione del Database
3.1.10

Ultima versione
3.2.0
Annuncio
https://www.phpbb.com/community/viewtop ... &t=2399606
Aggiornamento incompleto
Abbiamo notato che l’ultimo aggiornamento dell’installazione di phpBB non è stato completato. Clicca su database_update script ed eseguilo. Se questo non è presente, scarica il pacchetto di aggiornamento relativo alla tua versione; carica la cartella "install" nella root in cui è installato phpBB (dove è situato il file config.php) ed esegui lo script di aggiornamento del database."

faccio click su "database_update" ricomincia l'update e si ferma sempre e comunque nella pagina sopra indicata con l'errore descritto ("The installer detected a timeout
The installer has detected a timeout, you may try to refresh the page, which may lead to data corruption. We suggest that you either increase your timeout settings or try to use the CLI.")

Chi sa come poter aggiornare il database? .. Dov'è che sbaglio?

Grazie in anticipo....

Avatar utente
Barrnet
Leader Moderatori
Leader Moderatori
Messaggi: 3123
Iscritto il: 04/07/2010, 23:31
Sesso: Maschio
Versione: 3.0.10
Server: UNIX/Linux
PHP: 5.3.10
Database: MySQL 5.1.61-community-log
Contatta:

Re: Errore in aggiornamento...

Messaggio da Barrnet » 13/01/2017, 22:56

Il tuo hosting ha un timeout per gli script PHP troppo basso, oppure il forum è troppo grosso per essere umanamente aggiornabile online. Se il tuo hosting ti consente l'accesso via SSH, prova ad aggiornarlo via riga di comando (c'è una cartella cli con gli script appositi da avviare), altrimenti dovrai scaricare il forum in locale, aggiornare il database in locale e poi ricaricarlo.

Avatar utente
Sir Xiradorn
Grafico
Grafico
Messaggi: 1655
Iscritto il: 11/08/2009, 12:41
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux
PHP: 5.6.15
Database: MariaDB 10.1.9
Località: Lontano....
Contatta:

Re: Errore in aggiornamento...

Messaggio da Sir Xiradorn » 14/01/2017, 0:29

Sarebbe possibile avere un link al tuo forum per favore?
Sir Xiradorn
Immagine
~ XDojo - Xiradorn Lab Division - xiradorn.it ~
~ GitHub - XiradornLab ~

Immagine
Stargate - phpbb 3.0.x || 3.1.x || 3.2.x

roybell
Utente
Utente
Messaggi: 5
Iscritto il: 13/01/2017, 9:15
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux

Re: Errore in aggiornamento...

Messaggio da roybell » 14/01/2017, 10:36

@Barrnet graaie per la info. Il forum non è assolutamente grosso in quanto installato da poco e (a parte qualche spammer) non ci sono iscritti e post.
L'hosting non permette di fare nulla.... :(
"altrimenti dovrai scaricare il forum in locale, aggiornare il database in locale e poi ricaricarlo."
Mi sa che faccio prima a cancellarlo e reinstallare la 3.2 nuova.

roybell
Utente
Utente
Messaggi: 5
Iscritto il: 13/01/2017, 9:15
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux

Re: Errore in aggiornamento...

Messaggio da roybell » 14/01/2017, 10:57

@Sir Xiradorn tra il messaggio precedente e questo ho fatto che reinstallare il tutto....
il link è: https://www.inarte.it/forums/

Avatar utente
Sir Xiradorn
Grafico
Grafico
Messaggi: 1655
Iscritto il: 11/08/2009, 12:41
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux
PHP: 5.6.15
Database: MariaDB 10.1.9
Località: Lontano....
Contatta:

Re: Errore in aggiornamento...

Messaggio da Sir Xiradorn » 14/01/2017, 14:37

Comunque la tecnica migliore è quella data da barnet. Addirittura per avere meno peso e più potenza, potresti farlo da locale con interfaccia cli o da comando. Il tutto ti permette di ottenere il massimo della potenza e una possibilità maggiore di non avere dei timeout o interruzione degli script php per via del raggiungimento della potenza massima
Sir Xiradorn
Immagine
~ XDojo - Xiradorn Lab Division - xiradorn.it ~
~ GitHub - XiradornLab ~

Immagine
Stargate - phpbb 3.0.x || 3.1.x || 3.2.x

lucablue
Utente
Utente
Messaggi: 11
Iscritto il: 17/07/2011, 16:50
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux
PHP: 7.0
Database: 10.0.23-MariaDB-log - MariaDB Server

Re: Errore in aggiornamento...

Messaggio da lucablue » 24/01/2017, 12:45

Ciao Ragazzi,
continuo questo post perché ho lo stesso errore ma la domanda mia è un'altra:

Ho questo timeout, al primo UPDATE ho messo nei setting l'opzione FTP, inserendo i vari dati. Siccome mi da questo errore volevo provare in modo manuale, cioé come è sempre stato fatto prima: scarico i file da modificare e li ricarico io via ftp, ma non c'è modo di tornare indietro.

Voglio dire: se ricarico la pagina UPDATE non mi fa più scegliere il metodo o i settings, mi riporta direttamente alla pagina finale dove devo cliccare solo su UPDATE FILE...

Ho provato a cancellare e ricaricare i file di install ma nulla è cambiato... come si fa? Ha memorizzato qualcosa nel DB? Dove?

lucablue
Utente
Utente
Messaggi: 11
Iscritto il: 17/07/2011, 16:50
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux
PHP: 7.0
Database: 10.0.23-MariaDB-log - MariaDB Server

Re: Errore in aggiornamento...

Messaggio da lucablue » 25/01/2017, 12:23

Nessuno sa darmi una mano?
Devo ricaricare il backup di file e db e rifare l'aggiornamento?

Sono tanti MB :(

lucablue
Utente
Utente
Messaggi: 11
Iscritto il: 17/07/2011, 16:50
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux
PHP: 7.0
Database: 10.0.23-MariaDB-log - MariaDB Server

Re: Errore in aggiornamento...

Messaggio da lucablue » 25/01/2017, 17:45

Alla fine ho cancellato tutto, ho ripristinato il mio backup e rifatto l'aggiornamento in modo "standard", cioé scaricando i file manualmente e caricandoli via FTP.

Mi ha aggiornato il forum correttamente ma non funziona con php 7.0 ( vedi altro topic ), in pratica non mi si connette al DB...

Avatar utente
Sir Xiradorn
Grafico
Grafico
Messaggi: 1655
Iscritto il: 11/08/2009, 12:41
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux
PHP: 5.6.15
Database: MariaDB 10.1.9
Località: Lontano....
Contatta:

Re: Errore in aggiornamento...

Messaggio da Sir Xiradorn » 26/01/2017, 11:34

Controlla il file di config. Se me lo mandi via pm ti dico cosa correggere
Sir Xiradorn
Immagine
~ XDojo - Xiradorn Lab Division - xiradorn.it ~
~ GitHub - XiradornLab ~

Immagine
Stargate - phpbb 3.0.x || 3.1.x || 3.2.x

Rispondi

Torna a “[3.2.x] Forum di Supporto”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite