phpBB Italia chiude!
phpBB Italia ringrazia tutti gli utenti che hanno dato fiducia al nostro progetto per ben 9 anni, e che, grazie al grande lavoro fatto da tutto lo Staff (rigorosamente a titolo gratuito), hanno portato il portale a diventare il principale punto di riferimento italiano alla piattaforma phpBB.

Purtroppo, causa motivi personali, non ho più modo di gestirlo e portarlo avanti. Il forum viene ora posto in uno stato di sola lettura, nonché un archivio storico per permettere a chiunque di fruire di tutte le discussioni trattate.

Il nuovo portale di assistenza per l'Italia di phpBB diventa phpBB-Store.it, cui ringrazio per aver deciso di portare avanti questo grande progetto.

Grazie ancora,
Carlo - Amministratore di phpBB Italia

Hosting stabile

Scegli l'hosting adatto alle tue esigenze e risolvi i tuoi dubbi. In questa sezione è possibile discutere di diversi generi di hosting (web, vps, game).
maurence
Utente
Utente
Messaggi: 146
Iscritto il: 04/09/2013, 9:17
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.4.45
Database: MySQL 5.5.52-cll-lve

Hosting stabile

Messaggio da maurence » 25/02/2015, 17:48

Scrivo qui perché dopo essere passato da un server condiviso su hosting24 che si bloccava sempre perché superavamo le risorse, ho effettuato una migrazione sull'hosting aziendeitalia.com, per poco più di un mese tutto tranquillo, ora il forum sta aumentando gli accessi, circa 500 univoci al giorno e 100/150 utenti connessi (basto sugli ultimi 45minuti)

Più volte si è presentato il problema dell'errore 50, alle mie rimostranze l'hosting (tramite ticket) prima ha aumentato il numero massimo di connnessioni al database, poi ha cambiato le configurazioni mysql, poi ha dato colpa al file .htaccess che lascio di seguito:

Codice: Seleziona tutto

# Lines That should already be in your .htacess
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>

#blocco spider
RewriteEngine On 
RewriteCond %{HTTP_USER_AGENT} ^BlackWidow [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Bot\ mailto:craftbot@yahoo.com [OR] 
RewriteCond %{HTTP_USER_AGENT} ^ChinaClaw [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Custo [OR] 
RewriteCond %{HTTP_USER_AGENT} ^DISCo [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Download\ Demon [OR] 
RewriteCond %{HTTP_USER_AGENT} ^eCatch [OR] 
RewriteCond %{HTTP_USER_AGENT} ^EirGrabber [OR] 
RewriteCond %{HTTP_USER_AGENT} ^EmailSiphon [OR] 
RewriteCond %{HTTP_USER_AGENT} ^EmailWolf [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Express\ WebPictures [OR] 
RewriteCond %{HTTP_USER_AGENT} ^ExtractorPro [OR] 
RewriteCond %{HTTP_USER_AGENT} ^EyeNetIE [OR] 
RewriteCond %{HTTP_USER_AGENT} ^FlashGet [OR] 
RewriteCond %{HTTP_USER_AGENT} ^GetRight [OR] 
RewriteCond %{HTTP_USER_AGENT} ^GetWeb! [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Go!Zilla [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Go-Ahead-Got-It [OR] 
RewriteCond %{HTTP_USER_AGENT} ^GrabNet [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Grafula [OR] 
RewriteCond %{HTTP_USER_AGENT} ^HMView [OR] 
RewriteCond %{HTTP_USER_AGENT} HTTrack [NC,OR] 
RewriteCond %{HTTP_USER_AGENT} ^Image\ Stripper [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Image\ Sucker [OR] 
RewriteCond %{HTTP_USER_AGENT} Indy\ Library [NC,OR] 
RewriteCond %{HTTP_USER_AGENT} ^InterGET [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Internet\ Ninja [OR] 
RewriteCond %{HTTP_USER_AGENT} ^JetCar [OR] 
RewriteCond %{HTTP_USER_AGENT} ^JOC\ Web\ Spider [OR] 
RewriteCond %{HTTP_USER_AGENT} ^larbin [OR] 
RewriteCond %{HTTP_USER_AGENT} ^LeechFTP [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Mass\ Downloader [OR] 
RewriteCond %{HTTP_USER_AGENT} ^MIDown\ tool [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Mister\ PiX [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Navroad [OR] 
RewriteCond %{HTTP_USER_AGENT} ^NearSite [OR] 
RewriteCond %{HTTP_USER_AGENT} ^NetAnts [OR] 
RewriteCond %{HTTP_USER_AGENT} ^NetSpider [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Net\ Vampire [OR] 
RewriteCond %{HTTP_USER_AGENT} ^NetZIP [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Octopus [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Offline\ Explorer [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Offline\ Navigator [OR] 
RewriteCond %{HTTP_USER_AGENT} ^PageGrabber [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Papa\ Foto [OR] 
RewriteCond %{HTTP_USER_AGENT} ^pavuk [OR] 
RewriteCond %{HTTP_USER_AGENT} ^pcBrowser [OR] 
RewriteCond %{HTTP_USER_AGENT} ^RealDownload [OR] 
RewriteCond %{HTTP_USER_AGENT} ^ReGet [OR] 
RewriteCond %{HTTP_USER_AGENT} ^SiteSnagger [OR] 
RewriteCond %{HTTP_USER_AGENT} ^SmartDownload [OR] 
RewriteCond %{HTTP_USER_AGENT} ^SuperBot [OR] 
RewriteCond %{HTTP_USER_AGENT} ^SuperHTTP [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Surfbot [OR] 
RewriteCond %{HTTP_USER_AGENT} ^tAkeOut [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Teleport\ Pro [OR] 
RewriteCond %{HTTP_USER_AGENT} ^VoidEYE [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Web\ Image\ Collector [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Web\ Sucker [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebAuto [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebCopier [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebFetch [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebGo\ IS [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebLeacher [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebReaper [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebSauger [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Website\ eXtractor [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Website\ Quester [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebStripper [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebWhacker [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WebZIP [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Wget [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Widow [OR] 
RewriteCond %{HTTP_USER_AGENT} ^WWWOFFLE [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Xaldon\ WebSpider [OR] 
RewriteCond %{HTTP_USER_AGENT} ^Zeus  [OR]
RewriteCond %{HTTP_USER_AGENT} ^Baiduspider [OR]
RewriteCond %{HTTP_USER_AGENT} ^Yandex 
RewriteRule ^.* - [F,L]

# proteggi htaccess file
<Files .htaccess>
order allow,deny
deny from all
</Files>

ErrorDocument 401 /phpBB3/errore401.php
ErrorDocument 404 /phpBB3/errore404.php
ErrorDocument 403 /phpBB3/errore403.php
ErrorDocument 500 /phpBB3/errore500.php
ErrorDocument 503 /phpBB3/errore503.php
Poi mi hanno detto ciò:
aziendeitalia ha scritto:Questo è il carico del server in questo momento:

load average: 53,58, 35,18, 28,71

Si tratta di valori spropositati, o il sito è 'rotto' oppure ha un portale enorme.
Ora io ho caricato solo phpbb 3.1.3 nulla di assurdo.

Cosa posso fare cambiare hosting? O effettivamente 'è qualcosa che non va?

Aggiornamento:

Mi scrivono dopo la mia ennesima lamentala:
ora è nella norma; load average: 3,01, 3,76, 4,68
Difatti ora il forum va una meraviglia.

Mi sto snervando.

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7237
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Hosting stabile

Messaggio da Angolo » 25/02/2015, 19:36

1 - Stile validato?
2 - Estensioni validate?

Se la risposta a entrambe le domande è no.. provvedi. E dopo si vede.
Se la riposta è sì... stiamo parlando di passaggio da condiviso a condiviso.
Dobbiamo tenere presente che Ascraeus, è una nuova serie, e non abbiamo dati sufficienti, per fare valutazioni. Sappiamo che richiede più risorse di Olympus. Se il Forum fosse con la 3.0.X, sarebbe anomalo tutto questo. Ma non sappiamo se è anomalo con Ascraeus. Ormai è inutile piangere sul latte versato (hai aggiornato).
Io fossi al posto tuo, se il problema si ripresenta, farei un ultimo passaggio verso un host di una certa qualità. Stabilisci tu quale. Se il problema si ripresenta anche lì... logica vorrebbe un passaggio, quanto meno, verso un semidedicato. Ma sarebbe discutibile per un Forum con meno di 200 utenti connessi contemporaneamente, che non ha mai raggiunto i 300 (questi sono i dati che leggo).
Potrebbe essere anche un problema di Ascraeus... nessuno può dirlo con sicurezza...
Noi è da molti mesi che raccomandiamo cautela, e sconsigliamo di aggiornare...

Intanto, fai una cosa semplice semplice... svuota la cache e ripara le tabelle... e vedi come va.

Quello che si dovrebbe capire, è se in entrambi gli host da te usati, si presenta/presentava il medesimo problema!
Se fosse lo stesso.. il sospetto di bug, sarebbe da approfondire.

maurence
Utente
Utente
Messaggi: 146
Iscritto il: 04/09/2013, 9:17
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.4.45
Database: MySQL 5.5.52-cll-lve

Re: Hosting stabile

Messaggio da maurence » 25/02/2015, 19:52

Allora prima eravamo su condiviso ora sono su server cloud dedicato con ip.

L'errore si presentava anche prima con 3.0.12 per questo ho cambiato hosting e fino a ieri e anche ora dopo che mi sono lamentato tutto il giorno con l'hosting pare andare benissimo e reggere il carico.

Quando ho fatto il passaggio alla 3.1.2 ho riportato il 3.0.12 alle tabelle base eliminando tutte le modifiche, oggi ho solo quick reply non validata ed il tema bit, ma anche con prosilver ugualmente ho gli stessi problemi.

Davvero penso sia un bug che mi sono portato dietro dalla 3.0.12.

Ho letto sul web che ad altri che capita questo problema (altre piattaforme altri hosting) avevano un problema di .htaccess (l'ho letto poco fa) devo indagare questa è la fonte ma ancora devo leggere bene il tutto: Fonte

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7237
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Hosting stabile

Messaggio da Angolo » 25/02/2015, 20:01

Be'... se si presentava anche con Olympus.. è proprio un problema di host.. salvo qualche problema latente nel database... quando hai ripulito il database con l'stk, il database, risultava integro?

maurence
Utente
Utente
Messaggi: 146
Iscritto il: 04/09/2013, 9:17
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.4.45
Database: MySQL 5.5.52-cll-lve

Re: Hosting stabile

Messaggio da maurence » 25/02/2015, 20:03

Si risultava integro e senza nessun problema.

Aggiornamento filato liscio e senza problemi.

P.S. Il 3.0.12 lo avevo sul vecchio Host condiviso poi ho migrato e sul nuovo Host ho subito aggiornato quindi non so se il problema si sarebbe presentato anche con la 3.0.12 sul nuovo Host condiviso ma ho la sensazione di si e che vi sia un bug, loop da qualche parte.

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7237
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Hosting stabile

Messaggio da Angolo » 25/02/2015, 20:14

Non ho capito... il problema si è presentato anche con una versione della serie 3.0.X? Sì o no?

maurence
Utente
Utente
Messaggi: 146
Iscritto il: 04/09/2013, 9:17
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.4.45
Database: MySQL 5.5.52-cll-lve

Re: Hosting stabile

Messaggio da maurence » 25/02/2015, 20:42

Angolo ha scritto:Non ho capito... il problema si è presentato anche con una versione della serie 3.0.X? Sì o no?
Si ma sull'altro hosting.

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7237
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Hosting stabile

Messaggio da Angolo » 25/02/2015, 21:12

In tutti i casi si può escludere Ascraeus, se il problema era il medesimo. Il file .htaccess nativo del phpBB3, in modalità standard.. non ha impostazioni che possano alterare chissà cosa (cosa farebbe questo host, se avessi una SEO???).
È più facile che siano impostazioni balorde dell'host.. Non so da quale host provieni.. ma hai usato un host di un certo livello? Domanda retorica.
Vedi come va.. ma se decidi di fare un terzo tentativo, a questo punto, fallo verso un host di una certa qualità (stabilisci tu quale). Ovviamente, server linux.


P.S.
Si parla di eccesso di redirect nella fonte da te citata. In effetti, anche cliccando sulla Home del tuo sito.. appare un redirect, che non dovrebbe apparire.. ma se le cose stanno così, significa che sei passato da un host configurato a membro di segugio, verso un altro host configurato sempre a membro di segugio. Oppure, dai tu, una qualche configurazione o inserisci un qualche script... discutibile.

maurence
Utente
Utente
Messaggi: 146
Iscritto il: 04/09/2013, 9:17
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.4.45
Database: MySQL 5.5.52-cll-lve

Re: Hosting stabile

Messaggio da maurence » 25/02/2015, 23:18

Angolo, più volte ti ho ringraziato e lo faccio ancora una volta.

Tra le tue righe c'era la risposta al mio problema.

Il file .htaccess che mi portavo dietro aveva un comando errato un rewrite di troppo che creava come un loop o comunque mandava in tilt qualcosa.

Ho preso il .htaccess nativo di phpbb 3.1.3 ho aggiunto alcune regole che avevo già (controllate che fossero corrette) ed ora non ho alcun problema, anzi va alla perfezione.

Probabilmente ho cambiato hosting inutilmente, forse andava ancora bene il precedente condiviso, va bhe mi ritrovo comunque con un server dedicato seppur virtuale, che male non fa.

maurence
Utente
Utente
Messaggi: 146
Iscritto il: 04/09/2013, 9:17
Sesso: Maschio
Versione: 3.1.10
Server: UNIX/Linux
PHP: 5.4.45
Database: MySQL 5.5.52-cll-lve

Re: Hosting stabile

Messaggio da maurence » 26/02/2015, 18:45

Scusate se rispondo nuovamente.

Nel log_error, mi trovo ciò tutto il giorno:

Codice: Seleziona tutto

mod_fcgid: can't apply process slot for /var/www/php-fcgi-scripts/web2/.php-fcgi-starter
Da cosa può dipendere, cosa posso chiedere di fare all'hosting, o posso fare io?

Rispondi

Torna a “Hosting”

Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti