Problema strano con PHPBB Premod e rewriting urls

La versione di phpBB pre-moddata con tutte le MODs targate phpBB SEO.
Rispondi
mucciozz
Utente
Utente
Messaggi: 23
Iscritto il: 17/07/2013, 1:33
Sesso: Maschio
Versione: 3.1.5
Server: UNIX/Linux
PHP: 5.3.25
Database: MySQL(i) 5.1.61-0+squeeze1

Problema strano con PHPBB Premod e rewriting urls

Messaggio da mucciozz » 15/05/2014, 14:27

Allora, parto col dire che ho altri due forum, configurati IDENTICI, sullo stesso hosting (multidominio).
E' TUTTO identico, cambia semplicemente il colore e il nome del forum.

Veniamo al problema: nel nuovo forum, che sto aprendo, ho un problema di rewriting url.
Si avvera quando entro in una cartella. Mi spiego: il forum è installato in www.mt125.it/forum/...
Con il rewriting attivo (ripeto: configurato identici agli altri due forum, funzionanti perfettamente), se sono dentro ad -ipotizziamo/esempio- offtopic, mi trovo nel link www.mt125.it/forum/off-topic/...
Qualora cliccassi su admin panel, in basso, l'indirizzo a cui punta, e quindi mi da errore 404, è www.mt125.it/forum/off-topic/adm/... anzichè www.mt125.it/forum/adm/..., che sarebbe quello corretto.
Stesso problema per i RANK_IMG.. Non appaiono per lo stesso motivo: se faccio "mostra link immagine" sul RANK_IMG, mi dice che punta a www.mt125.it/forum/off-topic/images/ranks... anzichè www.mt125.it/forum/images/ranks..., che sarebbe quello corretto.

Idee per risolvere??

Angolo
Leader Traduttori
Leader Traduttori
Messaggi: 7230
Iscritto il: 11/03/2011, 17:37
Sesso: Maschio
Versione: 3.0.12
Server: UNIX/Linux
PHP: 5.6.18
Database: MySQL 5.6.33-log
Contatta:

Re: Problema strano con PHPBB Premod e rewriting urls

Messaggio da Angolo » 15/05/2014, 18:43

Io non ho capito niente. Indica solo due link col tag code, in modo che si possa rilevare la differenza. Rispiega la problematica, perché almeno a me, non risulta per niente chiara.

mucciozz
Utente
Utente
Messaggi: 23
Iscritto il: 17/07/2013, 1:33
Sesso: Maschio
Versione: 3.1.5
Server: UNIX/Linux
PHP: 5.3.25
Database: MySQL(i) 5.1.61-0+squeeze1

Re: Problema strano con PHPBB Premod e rewriting urls

Messaggio da mucciozz » 15/05/2014, 19:08

La problematica è, con Rewrite ON.
Se io sono dentro la sezione OFF-TOPIC (è un esempio, posso essere in qualsiasi sezione), lui giustamente mi fa vedere il link mt125.it/forum/off-topic/ nella barra link.

A questo punto qui, se io clicco sul pannello di controllo amministratore, anzichè linkare -come dovrebbe- a mt125.it/forum/adm/.., mi linka a mt125.it/forum/off-topic/adm/... e ovviamente non va, poichè c'è /off-topic/ di troppo.

Stessa cosa con altre funzioni, come ad esempio il RANK_IMG (nel link è presente /off-topic/ e non dovrebbe esserci), quindi non funziona.

mucciozz
Utente
Utente
Messaggi: 23
Iscritto il: 17/07/2013, 1:33
Sesso: Maschio
Versione: 3.1.5
Server: UNIX/Linux
PHP: 5.3.25
Database: MySQL(i) 5.1.61-0+squeeze1

Re: Problema strano con PHPBB Premod e rewriting urls

Messaggio da mucciozz » 15/05/2014, 22:17

Risolto, avevo per sbaglio sovrascritto la cartella template con quella di una subsilver2 senza premod.

Tutto ok! :geek:

Rispondi

Torna a “phpBB SEO Premod”

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite