phpBB Italia chiude!
phpBB Italia ringrazia tutti gli utenti che hanno dato fiducia al nostro progetto per ben 9 anni, e che, grazie al grande lavoro fatto da tutto lo Staff (rigorosamente a titolo gratuito), hanno portato il portale a diventare il principale punto di riferimento italiano alla piattaforma phpBB.

Purtroppo, causa motivi personali, non ho più modo di gestirlo e portarlo avanti. Il forum viene ora posto in uno stato di sola lettura, nonché un archivio storico per permettere a chiunque di fruire di tutte le discussioni trattate.

Il nuovo portale di assistenza per l'Italia di phpBB diventa phpBB-Store.it, cui ringrazio per aver deciso di portare avanti questo grande progetto.

Grazie ancora,
Carlo - Amministratore di phpBB Italia

Problema con traduzione

Traduzioni in fase di sviluppo.
Rispondi
Avatar utente
vargas
Utente
Utente
Messaggi: 280
Iscritto il: 11/03/2014, 7:59
Sesso: Maschio
Versione: 3.2.0
Server: Windows
PHP: 5.3.10
Database: MySQL 5.1.71-community-log

Problema con traduzione

Messaggio da vargas » 19/10/2015, 7:37

Ciao, premetto di non capre quasi nulla di linguaggio html & co, ma altre volte avevo provato con successo, stavolta ho un problema...

Ho provato a tradurre la ext "youtube video gallery", l'ultima versione, ed ho riscontrato un problema, credo sia una cavolata ma non riesco...

Praticamente, da n certo punto in avanti, esattamente da

Codice: Seleziona tutto

	// ACP Categories
, le scritte, come quella e quelle sotto, originariamente verdi, sono grigie, e le tfrasi tradotte sono nere anzichè grigie.

Pertanto, quando metto la cartella "it" nella ext, il forum sparisce :-(

Qualcuno può - vuole aiutarmi?
Allego il file "incriminato", grazie....
it.zip
Non hai i permessi necessari per visualizzare i file allegati in questo messaggio.
Immagine

Avatar utente
brunino
Moderatore
Moderatore
Messaggi: 2819
Iscritto il: 12/01/2013, 16:35
Sesso: Maschio
Versione: 3.1.2
Server: UNIX/Linux
PHP: php 5.3
Database: mysql
Località: Toscana, Firenze
Contatta:

Re: Problema con traduzione

Messaggio da brunino » 19/10/2015, 7:58

È il classico problema degli apostrofi... Nelle traduzioni, come apostrofo devi usare questo: ’ e non il classico ', perché altrimenti il codice PHP non gira.

Inviato dal mio MotoE2(4G-LTE) utilizzando Tapatalk
E' sempre gradito un grazie

Creo estensioni per phpBB 3.1 su misura: contattami via MP.
Mie Estensioni: Top Ten Topics | Ban List | Topic List
Visita il mio forum di test e sviluppo stili e estensioni phpBB 3.1

Avatar utente
vargas
Utente
Utente
Messaggi: 280
Iscritto il: 11/03/2014, 7:59
Sesso: Maschio
Versione: 3.2.0
Server: Windows
PHP: 5.3.10
Database: MySQL 5.1.71-community-log

Re: Problema con traduzione

Messaggio da vargas » 19/10/2015, 11:13

Grazie, ma non trovo quell'apostrofo sulla tastiera, pensa come sto messo...

Reinviarmi il mio common corretto? :-)
Poi credo che la traduzione vada bene, se volete potete aggiungerla a nome vostro nel forum, ne avrei piacere anzi
Immagine

Avatar utente
alex75
phpBB Expert
phpBB Expert
Messaggi: 943
Iscritto il: 31/03/2012, 23:46
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux
PHP: 5.6.37
Database: MySQL 5.6.39
Località: palermo
Contatta:

Re: Problema con traduzione

Messaggio da alex75 » 19/10/2015, 11:31

puoi anche usare questa forma

Codice: Seleziona tutto

\'

Avatar utente
brunino
Moderatore
Moderatore
Messaggi: 2819
Iscritto il: 12/01/2013, 16:35
Sesso: Maschio
Versione: 3.1.2
Server: UNIX/Linux
PHP: php 5.3
Database: mysql
Località: Toscana, Firenze
Contatta:

Re: Problema con traduzione

Messaggio da brunino » 19/10/2015, 11:34

La soluzione indicata da Alex non piace a phpBB.com

Non c'è sulla tastiera... Devi fare copia incolla da quello che ti ho messo... Generalmente (anche in questo caso) all'inizio viene indicato quel carattere proprio per fare copia-incolla
E' sempre gradito un grazie

Creo estensioni per phpBB 3.1 su misura: contattami via MP.
Mie Estensioni: Top Ten Topics | Ban List | Topic List
Visita il mio forum di test e sviluppo stili e estensioni phpBB 3.1

Avatar utente
Sir Xiradorn
Grafico
Grafico
Messaggi: 1659
Iscritto il: 11/08/2009, 12:41
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux
PHP: 5.6.15
Database: MariaDB 10.1.9
Località: Lontano....
Contatta:

Re: Problema con traduzione

Messaggio da Sir Xiradorn » 19/10/2015, 11:38

Esiste una ulteriore strada che permette di usare qualcosa che piace ad html e a phpbb ed è questa

Codice: Seleziona tutto

'
Sir Xiradorn
Immagine
~ XDojo - Xiradorn Lab Division - xiradorn.it ~
~ GitHub - XiradornLab ~

Immagine
Stargate - phpbb 3.0.x || 3.1.x || 3.2.x

Avatar utente
alex75
phpBB Expert
phpBB Expert
Messaggi: 943
Iscritto il: 31/03/2012, 23:46
Sesso: Maschio
Versione: 3.2.0
Server: UNIX/Linux
PHP: 5.6.37
Database: MySQL 5.6.39
Località: palermo
Contatta:

Re: Problema con traduzione

Messaggio da alex75 » 19/10/2015, 12:02

brunino ha scritto:La soluzione indicata da Alex non piace a phpBB.com
non lo sapevo, fino ad ora mai contestato (fortunato :mrgreen: )
comunque quando non c'è sulla tastiera, torna sempre utile l'informatica grezza di 30 anni fà...
codice ascii
Tieni premuto il tasto ALT di sinistra e digita sul tastierino numerico 0146 e avrai questo ’

Rispondi

Torna a “In sviluppo”

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti